gspca in Linux 2.6.27

only works with v4l2, but not v4l. So it can lead to problems - programs using v4l gives strange pictures as well as annoying error messages.

My webcam worked with gspcav1 and Linux 2.6.26, but it failed in Linux 2.6.27 (with its in-kernel gspca drivers):
>>cmcapture err -1
cvsync err
: Invalid argument
cmcapture: Invalid argument

Solution: Install libv4l, and use a command like this:LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype.

Reference
Linux kernel bug #11860.

1 comment: